スポンサーサイト
上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。
【--/--/-- --:--】 | スポンサー広告 | page top↑
XSI7.01常用けってい!
以前失敗したXSI7のサテライトレンダリング
他サイトを見て
setenv.batに
set MI_FORCE_OLD_BSP=1
の謎の言葉を入れ込むと動作すると書いてあったので試してみたんだけど
コレがウチの環境では動かず・・・
XSIのIRCで32bit環境では動いていますよ
との事でコレは最後の手段XP32bitに だうんぐれぇーど!!
と考えていた矢先の7.01リリース!
コレは試さずには

こんなシーン作って(ちょー手抜き)
WS000004.jpg

れっつ サテライト ごぉー!
結果やはり素のままではサテライトレンダリング失敗いたしますわ・・・

試しにset MI_FORCE_OLD_BSP=1を入れると

あら!?不思議!!

WS000002.jpg


レンダリングできましたとさ

いままで2枚目のレンダリングでエラーを吐いていたのが
3枚目以降もレンダリングちゃーんと動いております。

コレでXSI7を常用可能となりました

おつかれっしたぁー
スポンサーサイト
【2008/11/29 02:21】 | XSI | トラックバック(0) | コメント(0) | page top↑
XSI7.01 リリース
Autodeskになってごたごたしてるだろうから
遅くなると思ってたのに
結構速くリリースされましたね

http://www.softimage.com/downloads/
とりあえずダウンロード中!

ついでにFix箇所リスト
ネットワークレンダリング直ってるといいなぁ

http://www.softimage.com/downloads/lists/7_01/XSIv701_Fixed.txt

Softimage | XSI v7.01 - Fixed Bugs list

***Driver Issues***
NOTE: The following fixes are addressed by the latest ATI driver (see Downloads)

UDEV00248043 - ATI: fails to compile specific GLSL Program fragment shader
UDEV00248154 - ATI: zooming in and out of any ICE graphs causes a memory leak
UDEV00247727 - ATI: Objects (polygon mesh) disappear when moving points
UDEV00247699 - ATI: Duplicate of polygons With weight map Causes crash
UDEV00247685 - ATI: memory leak with Render Tree
UDEV00247025 - ATI + Linux 64bit: Displaying PPG with Fcurve causes XSI to crash
UDEV00246655 - ATI: XSI hangs when interacting with "heavier" mesh
UDEV00246512 - ATI: Exporting object causes XSI to crash (Viewport is not refreshing)
UDEV00245991 - ATI: Right-Click to bring up contextual menu after Edge Selection causes XSI to crash
UDEV00245991 - ATI: Right-Click after Edge Selection causes XSI to crash
UDEV00243493 - ATI + Linux 64bit: XSI freezes when loading layouts (ex: default and ICE layouts)
UDEV00243400 - ATI: Selection is slow with high density wireframe

NOTE: The following fixes are addressed by the latest nVIDIA drivers (starting with driver 177.92)
UDEV00248081 - nVIDIA GeForce cards - ImageClip Editor: Browsing for a texture image causes XSI to crash
UDEV00248029 - nVIDIA GeForce cards: Opening the image clip properties for textures causes XSI to crash

***Animation***
UDEV00249573 - Opening the DopeSheet may cause XSI to crash
UDEV00249063 - Regression in performance when keying multiple objects
UDEV00248706 - Local kinematic limits error on imported scenes/models from XSI 6.5
UDEV00248516 - "Error:2011-EDIT-SetValue - Member not found" error when you edit the Pos Limits on a duplicated object
UDEV00247875 - Saving a fraw2 file from an FCurve can cause XSI to crash
UDEV00247596 - Plotting character can cause XSI to crash when using continuous rotation option
UDEV00247289 - Changing mixer connections after freezing to new source can cause XSI to crash
UDEV00246554 - FCurve Editor: possible memory problem with undo\redo
UDEV00242627 - Connection resolution template dialog showing up when attempting to save key in Layers

***Audio***
UDEV00244765 - Sound file not playing (mp3 Compression)

***Converters / Import / Export***
UDEV00249144 - Crosswalk custom Property does not keep its values
UDEV00248830 - Batch exporting particle instances deletes assemblies
UDEV00248476 - Import / Export of DirectX format does not work
UDEV00247294 - Point Oven: Exporting to an unexistant folder or to a write-protected file may cause XSI to crash
UDEV00247221 - Point Oven does not always export when scripted in python

***Data Management***
UDEV00249218 - Refmodel does not correctly unload - Groups are skipped
UDEV00248956 - RefModel load time is longer in v7.0
UDEV00248496 - RefModels: interaction issues with operatoss on kinematics
UDEV00248157 - ICE: Strand caching is wrong when strand segment number changes over time
UDEV00248131 - Refmodels load index are changed when reparented inside a different model
UDEV00248115 - Materials numbered in Material Library when Import Model
UDEV00247962 - RefModel workflow issues with Envelope changes after file save using Weight Editor Preset
UDEV00247638 - RefModel problems in pose constraints evaluation
UDEV00247575 - Texture Map link lost when loading the same RefModel two times in the same scene
UDEV00247326 - Expression on mixer parameters gets removed and stored separately in the delta even if the mixer is not stored in it
UDEV00247276 - Long Save time & Envelope Disappearing Scenes & workgroups

***Games***
UDEV00248792 - GetAttributeList callback only called once per material

***Modeling***
UDEV00248530 - AddInputToOperator gives an error in XSI 7.0 causing XSI to crash
UDEV00247795 - ICE-Cycle breaking point with weight maps when moving ICEtree in the stack
UDEV00247765 - Scene explorer causes XSI to crash (fake node) when freezing a history stack with a deleted ICE op
UDEV00247321 - Duplicate Symmetry Tool error 2011 with XSI 5.11 models

***Performance***
UDEV00248901 - Linux64 playback issue

***Rendering***
UDEV00249561 - Make local does not work for pass properties
UDEV00249546 - Standin callbacks for 3rd party renderers do not work
UDEV00249322 - Loading RTCompound causes XSI to crash
UDEV00249271 - Image node (Softimage.txt2d-image-explicit.1) becomes a port name
UDEV00249182 - Can not edit a CgProgram code
UDEV00248912 - Delete unconnected nodes deletes environment shaders connected to passes
UDEV00248908 - Changing the Shaderball > Quality preference to Low causes XSI to crash
UDEV00248742 - Isolate selection does not affect render-region
UDEV00248694 - Bumpmap with Architectural Material renders very slow
UDEV00248675 - Ray3 causes XSI to crash when it detects subdivision on any objects
UDEV00248567 - Preset manager: Exporting a Compound Shader removes the workgroup/user shader preset
UDEV00248548 - Loading the Vector to Color node from the top menu does not work
UDEV00248533 - ICE: Specific scene crashes on playback when using FilterPointsByConeAngle
UDEV00248522 - Elliptical filtering prevents shaders from caching
UDEV00248465 - Connections in Rendertree are not displayed
RESOLUTION: To force renesting set XSI_FORCE_SHADER_RENESTING_DURING_LOAD to 1 and load/save the scene to fix it. Don't forget to set the variable off afterwards as it will slow down scene loading.
UDEV00248386 - xsibatch eventually hangs when you run a sequence of xsibatch commands
UDEV00248322 - Incidence Node "Light List" is broken
UDEV00248275 - Specific scene hangs using preview region
UDEV00248235 - Pass Crop options are not working properly
UDEV00248233 - Render 4K image with FG preview ON freezes XSI
UDEV00248214 - sRGB space is not applied to images on scene reload
UDEV00248053 - mia_MaterialMultiOutput does not cast shadows
UDEV00247937 - Map lookup (scalar) sometimes stops working
UDEV00247881 - Hair shader with multiple UVs do not work properly
UDEV00247806 - "Texturable" is OFF by default in Ambient_Occlusion RenderTree node
UDEV00247738 - 16bit scalar maps and textue scalar do not render correctly
UDEV00247402 - Volume Cloud Shader Artifacts with .mi files
UDEV00247262 - Hidden Line Display and material with Transparency can cause XSI to crash
UDEV00246876 - Volumic light parameter with custom light shader is not working properly
UDEV00246365 - Fog with transparent objects produces artefacts
UDEV00244495 - Lightmaps: link to the file is always the same

***SDK & Scripting***
UDEV00248181 - GetAttributeValue not returning a value for "currentprojectionname"
UDEV00248174 - AddMaterial name sets name for incorrect node
UDEV00248122 - xsi_value.h: unknown format error on line 170 and 266 causes compile error
UDEV00248121 - Texture.fullname returns material library namespace value
UDEV00248016 - EvaluateClusterProperty() Method for evelopes can cause XSI to crash
UDEV00247753 - Model Dialog in siOnEndRefModelModLoad event can cause XSI to crash
UDEV00247251 - Mute parameter on custom operator not being updated like mute parameters on native operators
UDEV00244124 - Repetition of ExecuteCommand can cause AccessViolationException

***Setup and Licensing***
UDEV00249142 - libgcc_s.so.1 shipped with 64bit Linux version is actually 32bit
UDEV00248135 - Timing issue that could cause a crash when launching XSI and Internet at same time from the installer

***Simulation***
UDEV00249437 - ICE: Deleting character causes XSI to crash (ref. UDEV00249347)
UDEV00248887 - ICE: Scene that requires ICE tree resimulation on load causes XSI to crash
UDEV00248682 - ICE: General Cleanup of a few compounds
Set Particle Goal.1.1.xsicompound: Simplification of the compound removing unnecessary nodes
State Machine.1.1.xsicompound: Inside the State Machine, we were saving the Self.__HitFrameFraction value, which is no longer used by "Test Collision With Surface"
UDEV00248681 - ICE: Getting integer attribute at polygon mesh vertex neighbors returns wrong values
UDEV00248672 - ICE: Get Set Sum does not calculate the sum of the values in the set, instead it returns 1
UDEV00248668 - ICE: Neighbouring particles force causes XSI to crash after a certain number of particles
UDEV00248573 - ICE: Crash when a object cluster is used as filter in a "Generate Sample Node"
UDEV00248279 - ICE: Get Element Indices node can freeze evaluation
UDEV00248253 - ICE: Boolean To Integer node does not support Input Array
UDEV00248208 - ICE: Cluster change is not updated in graph (may cause random crashes)
UDEV00248207 - ICE: PointLocator can cause XSI to crash
UDEV00248184 - ICE: Creating Infinite loop execution with ICE compounds can freeze XSI
UDEV00248170 - ICE: Using non-uniform in getclosestlocation to curve returns incorrect position values
UDEV00248161 - ICE: Deleting groups or objects belonging to the group causes XSI to crash upon loading the scene
UDEV00248119 - ICE - Vista 64bit and Linux 32 bit: Stick on Surface freezes with NURBS surfaces on playback
UDEV00248068 - ICE: Connecting GetData Null into Sin input port causes XSI to crash
UDEV00248030 - ICE: Drag force can cause XSI to crash when changing the mode during playback
UDEV00247986 - ICE: On a new empty array the push node sets some data to index one and above
RESOLUTION: User data 2D arrays are now empty at start.
UDEV00247970 - ICE: Instance Shape node causes XSI to crash when using Wrap Around for index group out-of-range with an empty target
UDEV00247966 - ICE: Evaluating nodes outside of execution ports - graph specific
UDEV00247940 - ICE: undoing and redoing creation of a simulated ICE tree can cause XSI to crash
UDEV00247874 - ICE: Create compound sometimes does not connect inputs - order specific
UDEV00247866 - Merging Multiple Simulation Environments seems broken
UDEV00247831 - ICE : Stick to Surface does not work properly with multiple surfaces
UDEV00247764 - ICE unstable when evaluating "locations" attributes using "locations" input data
UDEV00247759 - XSI grows unstable when attempting to drive parameters with an ICE Graph with cycles
UDEV00247653 - Memory leak with specific scene
UDEV00246991 - ICE: Undo of delete nodes operation may cause general instability

***Texturing***
UDEV00248790 - Stamp UV Mesh causes XSI to crash
UDEV00248557 - Editing topology and re-running rendermap freezes XSI
UDEV00248081 - nVIDIA GeForce cards - ImageClip Editor: Browsing for a texture image causes XSI to crash
UDEV00248029 - nVIDIA GeForce cards: Opening the image clip properties for textures causes XSI to crash

***UI***
UDEV00249155 - Sliders range min/max problem with multiple selection
UDEV00248935 - Hide/Show explorer view in ICE Tree is broken
UDEV00248934 - Linux: getting shader nodes via the Render Tree Nodes menu does not always work
UDEV00248225 - Sliders Auto-Range is not working for siUInt4 parameters
UDEV00248145 - Linux: framecounter shows odd numbers when at negative numbers
UDEV00248110 - Obsolete Layers Panel on a Hotkey can cause XSI to crash
UDEV00247384 - Holding shift on MCP select menu does not change the chosen toggle
【2008/11/28 16:05】 | XSI | トラックバック(0) | コメント(0) | page top↑
Parallels健闘!!
先日検証したVM環境でのレンダリングテスト
Parallelsでもやってみた

結果は!
よいよい!!

理想にそこそこ近い結果をたたき出したよ

レンダリングしたのはXSIのサンプルにある
Rendertree_Surface_Glass
こいつをただレンダリングしただけでチェック!!

コレをBootcampでレンダリング
マシンはMacPro Xeon 2.8 X2 8Core
8min32Sec74
こんな感じ

VMWare Fusion 上のVista64(bootcamp領域)Xeon 2.8 2Core認識
32min59sec87

まぁ2Core認識なんで4分の1くらいのパフォーマンスか
こんなもんこんなもん

ほんで
Parallels上のXP64(bootcamp領域) Xeon 2.8 8Core認識(ひゃっほー!!)
8min54sec08
08112001.jpg

かなり速いな
コレならいける!!
Mac起動したままレンダのスレーブにできるじゃん

Masterマシン Bootcamp Xeon2.8X2 8Core
Slaveマシン Parallels上のXP64(bootcamp領域使用) Xeon 2.8 8Core認識
6min7Sec43
08112002.jpg

早くなったぞ!
と思いきや・・・

ちょいと落とし穴
サテライトレンダリングライセンスの物理CPU数なんだけど
コレがまたParallelsで認識した8Coreが
8っこの物理CPUと認識して
Slave側が50%の4CPUしか動いていなかった・・・
08112003.jpg

世の中うまくいかんのう・・・
2台のMacProでParallels起動し
スレーブにしてウハウハ状態にしたかったんだけど
勿体ないわ
でもローカルのみだと8Core使ってんだけどなぁ・・・
どうしてどうしてどうして・・・

でもマスターにしたときは8Core使ってるよなぁ・・・

さて検証! 検証!

まず整理してと
マシン1 MacPro01 8Core
マシン2 MacPro02 8Core
マシン3 PC Core2Duo3.0 2Core
物理CPUは5個と
ライセンス的にはマスター2CPU + サテライト4CPUだから足りてるわな
マスター = マシン1      2CPU
スレーブ = マシン2+マシン3 3CPU
コレでもまだフルには使ってないよな

Parallelsがいけないのか検証してみる
マスター マシン2(BootCamp Vista64)
スレーブ マシン1(bootcamp XP64 こいつにParallels入ってた)+マシン3(Vista64)
さてさて レンダリング・ ・ ・
5min9sec29

スコアは上がったが、やはり50%しか使わない・・・
なぜだ・・・
マスターで2CPUスレーブで3CPUでしょ
動いているからとりあえず制限を超えている訳ではなさそうだなぁ
実質スレーブ2CPUか

XP64が原因か検証
マスター マシン3(Vista64)
スレーブ マシン1(BootCamp Vista64)+マシン1(bootcamp XP64)
6min31sec49
がーん・・・
最初はVista側が50%超えて動いていたんだけど(100%ではなく80くらい)
すぐに50%に落ちてきた
結局両方とも終始50%近辺で動いてるわ

ちょいとXSIBaseのぞいてみたら
http://www.xsibase.com/forum/index.php?board=15;action=display;threadid=32609
ここに
•   UDEV00237836 - Raysat.exe does not render on all cores on a Dual Quad core s.ystem (8 CPU)
って書いてあるし
エキサイト翻訳君にかけたら
UDEV00237836--Raysat.exeはDual Quadコア・システムの上ですべてでコアをレンダリングしません。(8CPU)
だとさ・・・

でもまぁレンダリングに50しか使えんのなら他の作業もできるし
Parallelsも有効活用できるかな

今後の作業環境の方針は
制作時(モデリングやらアニメ付けやら)
マスター マシン3(グラフィックカードがMacProに比べて良いやつだから)
スレーブ マシン1でParallels+マシン2でbootcamp(もう1ライセンスParallels買ってもいいかな)

レンダリング時
マスター マシン2bootcamp(8Coreフル活用)
スレーブ マシン1Parallels(なんもしないならbootcampでもいいや)+マシン3(2Coreフル活用)
ってなな感じかなと
てかこんな事ならマシン組む時にE8400の2CoreじゃなくQuadのほうにしときゃ良かったなぁ

とりあえずサテライトレンダリングはXSI7のバグが直るまで検証終了だな
こんな事ばっかやってる時間あったらモデリングとかして
XSIの操作習得した方が効率的なのになぁ バカだな俺・・・

てか、うまくいかんものねー
【2008/11/20 05:53】 | 未分類 | トラックバック(0) | コメント(0) | page top↑
検証してみたが微妙だなぁ
意外と速いぞParallels
こちらのブログにあるVM環境でのレンダリングが気になったんで
ちょいとやってみた

とりあえず結果はまーウチの環境ではメリットがないかなぁ

まず作業環境から
マシン1 PC
PC E8400 VISTA64 XSI6.5
マシン2 MACPRO
MAC Xeon2.8 VMware Fusion VISTA64 XSI6.5

検証リスト
1、マシン1のみでのレンダリング
2、マシン2のみでのレンダリング(Bootcamp)
3、マシン1マスター、マシン2スレーブ(VMWare)
4、マシン2マスター(VMWare)、マシン1スレーブ
5、マシン1マスター、マシン2スレーブ(bootcamp)
6、マシン2マスター(bootcamp)、マシン1スレーブ

検証シーン
スフィアを5、6っこ置いて分割数上げてHDRIを環境に入れFGをかけた単純なシーン
アニメーションしてないが5枚ほどレンダリング

検証1 マシン1のみでのレンダリング
こいつは純粋なWindows環境
1f 26sec
2f 23Sec
3f 24Sec
4f 23Sec
5f 23Sec
計 119Sec
とりあえずこいつを基準にしますかな

検証2 マシン2のみでのレンダリング(Bootcamp)
MacProのBootcamp環境でレンダリング
1f 10Sec
2f 8Sec
3f 8Sec
4f 8Sec
5f 9Sec
計43Sec
ばかっぱや!
やっぱ8コアははやいなぁ
てかこの段階で他の検証意味ないような・・・

さて一応本題のVMでのレンダリング

検証3 マシン1マスター、マシン2スレーブ(VMWare)
1f 22Sec
2f 24Sec
3f 22Sec
4f 22Sec
5f 22Sec
計112Sec
検証3

まぁ こんなもんかぁ
VMWareFusionが2Coreまでしか割り当てられていないので
こんな感じの結果になりました。
PC一台よりかは速いけど大してかわらん・・・

次は実験だなぁ
検証4 マシン2マスター(VMWare)、マシン1スレーブ
1f 46Sec
2f 34Sec
3f 33Sec
4f 35Sec
5f 33Sec
計181Sec
検証3

まぁまぁ 健闘したなぁ
結局マスター2コアのスレーブも2コアだしなぁ

結局Macで作業してて落とせない時とかにちょいと参加させる感じだなぁ
追加しても微々たるもんだなぁ

こっからはロスタイム
検証5 マシン1マスター、マシン2スレーブ(bootcamp)
1f 24Sec
2f 20Sec
3f 19Sec
4f 20Sec
5f 20Sec
計103Sec
まぁまぁ速くなったぞとぉ~
にしてもタイムがばらつくなぁ
同じ絵をレンダリングしてもちょいちょい変わるのね
一枚目はデータ読み込みとかで遅くなるんかなぁ

さて本丸
検証6 マシン2マスター(bootcamp)、マシン1スレーブ
1f 15Sec
2f 8Sec
3f 9Sec
4f 10Sec
5f 12Sec
計54Sec
ン?
んが!?
一台でやるよりオセーじゃんかぁー
重いシーンじゃないからパフォーマンスでないのね・・・

途中で気づいたけど無駄だったなぁ・・・
パラレルの方は4CPUとか書かれていたので
CPU分ぶん回せるのかな
それならもーちょいスコアあがるべーな
また時間ある時にでも試してみるかな

それにサテライトレンダリング速くする事できんのかいなぁ
ネットワークのチューンだけではどうにもならなそうだなぁ
今度は重いシーンでためしてみますかなと!
【2008/11/17 18:58】 | XSI | トラックバック(0) | コメント(0) | page top↑
Parallelsかぁ・・・
意外と速いぞParallels
こんな記事を発見

Parallelsかぁ
サテライトレンダリングもスレーブ側があんまりフルにCPU使ってくれないし
仮想環境でレンダリングまわしても問題ないかなぁ
幸いParallelsもVMWAREもライセンス一個ずつ余ってるし
64bitのOSも追加したんで32bitXP余ってるし・・・
検証してみるかなぁ
【2008/11/16 00:29】 | XSI | トラックバック(0) | コメント(0) | page top↑
| ホーム |
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。